uim 1.5.7 を install

firefoxが落ちるのは uim が原因で,

1.5.7では fix されていると聞いたので.

しかし,pacmanからinstallしようと思ったら,まだなかった.

一昨日リリースだから,しかたないか.

パッケージない→自分でつくればよい.

というわけで,つくった.

といっても,absのをコピーしてきて,適切に変更するだけ.

ただ,自分は,gnomeもanthyも使わないから,そういものは除外した.

一応 PKGBUILD をのせておく.

pkgname=uim
pkgver=1.5.7
pkgrel=1
pkgdesc="Multilingual input method library"
arch=('i686' 'x86_64')
url="http://code.google.com/p/uim/"
license=('custom')
depends=('m17n-lib' 'ncurses' 'gtk2')
makedepends=('pkgconfig' 'gettext' 'intltool')
optdepends=('')
options=('!libtool')
install=uim.install
source=(http://uim.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
md5sums=('f8cf0c4f977f8f0496254040ba710de8')
sha1sums=('0792cc0e60b24fcfffaea2bcfeef8badd3098d98')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr  --libexecdir=/usr/lib/uim 
--disable-gnome-applet --without-anthy 
--without-mana --without-prime || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}