firefox 3.6 をインストールした.

f:id:jeneshicc:20100123001621p:image

今現在,なにが変わったのか分からない.

(追記:新しいタブを開くとすぐ右に開くようになった.いままでは最右端だった気がする)

自分でビルドしてインストールした.

PKGBUILDなどはAURのfirefox-brandedとほぼ同じ.

ただ,xulrunner-1.9.2が必要みたいだったので,ABSのtestingを利用してこれもビルドした.

ただ,そのままだとlibpngの1.4を必要とするが,ほとんどのアプリケーションがどうやら,1.2を利用するみたいなので,

PKGBUILDに若干の修正を加えた.

(追記:1.2が必須と思っていたが,VirtualBox内のArchlinuxで試したら,1.4でも問題なかった.)

(追記:2010/01/22 現在 testingではアップグレードしないのが推奨

http://mailman.archlinux.org/pipermail/arch-dev-public/2010-January/014993.html

動作にはいまのところ問題ないが,

LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/nppdf.so [/usr/lib/mozilla/plugins/nppdf.so: wrong ELF class: ELFCLASS32]

というメッセージがでる.

以下 PKGBUILDなど.

pkgname=firefox-branded
pkgver=3.6
pkgrel=2
_xulver=1.9.2
pkgdesc="Standalone web browser from mozilla.org"
arch=(i686 x86_64)
license=('MPL' 'GPL' 'LGPL')
depends=("xulrunner=${_xulver}" 'desktop-file-utils')
makedepends=('zip' 'pkgconfig' 'diffutils' 'python' 'wireless_tools')
replaces=('firefox' 'firefox3' 'firefox3-branded')
conflicts=('firefox' 'firefox3' 'firefox3-branded'
'firefox-pgo' 'firefox-pgo-beta'
'firefox-pgo-phenom' 'firefox-pgo-beta-phenom'
'firefox-pgo-core' 'firefox-pgo-beta-core')
provides=("firefox=${pkgver}")
install=firefox.install
url="http://www.mozilla.org/projects/firefox"
source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/source/firefox-${pkgver}.source.tar.bz2
mozconfig
firefox.desktop
firefox-safe.desktop
mozilla-firefox-1.-lang.patch
browser-defaulturls.patch
firefox-version.patch)
build() {
cd "${srcdir}/mozilla-1.9.2"
patch -Np1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch" || return 1
patch -Np0 -i "${srcdir}/browser-defaulturls.patch" || return 1
patch -Np1 -i "${srcdir}/firefox-version.patch" || return 1
cp "${srcdir}/mozconfig" .mozconfig
unset CFLAGS
unset CXXFLAGS
export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-3.6"
make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}" || return 1
make -j1 DESTDIR="${pkgdir}" install || return 1
rm -f ${pkgdir}/usr/lib/firefox-3.6/libjemalloc.so
install -m755 -d ${pkgdir}/usr/share/applications
install -m755 -d ${pkgdir}/usr/share/pixmaps
install -m644 ${srcdir}/mozilla-1.9.2/other-licenses/branding/firefox/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png || return 1
install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/ || return 1
install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/ || return 1
}
md5sums=('458051557ff49e6a352c1d56eee5782a'
'867d44ac248c839afa3cf584c7b42c75'
'ba96924ece1d77453e462429037a2ce5'
'5e68cabfcf3c021806b326f664ac505e'
'bd5db57c23c72a02a489592644f18995'
'8bf21158090c89fd834bb711aae0602e'
'92c11c66dd69b03f214002fededd1fc8')
pkgname=xulrunner
pkgver=1.9.2
_ffoxver=3.6
pkgrel=2
pkgdesc="Mozilla Runtime Environment"
arch=(i686 x86_64)
license=('MPL' 'GPL' 'LGPL')
depends=('gtk2>=2.18.3' 'gcc-libs>=4.4.2' 'libidl2>=0.8.13' 'mozilla-common' 'nss>=3.12.4' 'libxt' 'hunspell>=1.2.8' 'startup-notification>=0.10' 'mime-types' 'dbus-glib>=0.82' 'alsa-lib>=1.0.21.a')
makedepends=('zip' 'pkgconfig' 'diffutils' 'python' 'wireless_tools')
optdepends=('libgnomeui' 'python' 'wireless_tools')
provides=(gecko-sdk)
replaces=(gecko-sdk)
source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}.source.tar.bz2
mozconfig
mozilla-pkgconfig.patch
fix-mozilla-launcher.patch
mozilla-ps-pdf-simplify-operators.patch
xulrunner-version.patch
xulrunner-png14.patch)
build() {
cd "${srcdir}/mozilla-1.9.2"
cp "${srcdir}/mozconfig" .mozconfig
 #Upstream patch. Still not applied to 1.9.2
patch -Np1 -i "${srcdir}/mozilla-ps-pdf-simplify-operators.patch" || return 1
 #fix libdir/sdkdir - fedora
patch -Np1 -i "${srcdir}/mozilla-pkgconfig.patch" || return 1
 #Fix stub launcher - archlinux
patch -Np0 -i "${srcdir}/fix-mozilla-launcher.patch" || return 1
 #Force installation to the same path for every version
patch -Np1 -i "${srcdir}/xulrunner-version.patch" || return 1
 #patch -Np0 -i "${srcdir}/xulrunner-png14.patch" || return 1
unset CFLAGS
unset CXXFLAGS
export LDFLAGS="${LDFLAGS} -Wl,-rpath,/usr/lib/xulrunner-1.9.2"
make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
make -j1 DESTDIR="${pkgdir}" install || return 1
}
md5sums=('458051557ff49e6a352c1d56eee5782a'
'f372152464e3c991f1599c4a9b96ef11'
'd92adb0f23e724c1667baecb4cdaea80'
'63eee2d1da3b43c9d604f2253f242f40'
'13dca58c04e62a8916691c63c5c492a0'
'371303c5bdc4fa0d955d14521b93b69d'
'3bd0566180ad2daa32743b3ce58b2095')

gnomeは使わないので,mozconfigに

ac_add_options --disable-gnomeui
ac_add_options --disable-gnomevfs

を追加した.

More Reading
Newer// firefox 3.6